Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community Archives > Coral Forums > Soft Coral Keepers

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12/16/2007, 01:40 PM
Newlin Newlin is offline
Registered Member
 
Join Date: Jun 2005
Location: Noble, Ok.
Posts: 222
What is wrong with my leather?

I got this leather about two weeks ago and this is how it has looked since I put it in my tank. Everything else in my tank is thriving except this. I have tried to put it low, mid, and high in the tank with different waterflows and nothing has helped. What am I doing wrong here? Everything is normal in the tank and like I said, everything else is doing good. I also got a kenya tree that is doing very well too. And I got it at the same time as this one. Please help.

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 02:13 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef Central Reef Central, LLC. Copyright 1999-2009